<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns#" lang="en-gb" >
<head>
	        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=2.0">
      <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Candace Rojo Keyes,Flowers High School,high school football,National Signing Day" />
  <meta name="title" content="Charles H. Flowers celebrates six football college commits" />
  <meta name="author" content="Candace Rojo Keyes" />
  <meta property="og:url" content="http://www.thesentinel.com/pgs/index.php?option=com_k2&amp;view=item&amp;id=3399:charles-h-flowers-celebrates-six-football-college-commits&amp;Itemid=323" />
  <meta property="og:title" content="Charles H. Flowers celebrates six football college commits" />
  <meta property="og:type" content="article" />
  <meta property="og:description" content="SPRINGDALE – Charles H. Flowers Head Football Coach Dameon Powell could not hide his joy as he talked about his players and their futures. Last week,..." />
  <meta name="description" content="SPRINGDALE – Charles H. Flowers Head Football Coach Dameon Powell could not hide his joy as he talked about his players and their futures. Last week,..." />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>Charles H. Flowers celebrates six football college commits</title>
  <link href="http://www.thesentinel.com/pgs/templates/gk_gamenews/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
  <link href="http://www.thesentinel.com/pgs/index.php?option=com_search&amp;view=item&amp;id=3399:charles-h-flowers-celebrates-six-football-college-commits&amp;Itemid=323&amp;format=opensearch" rel="search" title="Search Prince George's Sentinel" type="application/opensearchdescription+xml" />
  <link rel="stylesheet" href="/pgs/media/system/css/modal.css" type="text/css" />
  <link rel="stylesheet" href="/pgs/templates/gk_gamenews/css/k2.css" type="text/css" />
  <link rel="stylesheet" href="/pgs/components/com_rsform/assets/calendar/calendar.css" type="text/css" />
  <link rel="stylesheet" href="/pgs/components/com_rsform/assets/css/front.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/tablet.css" type="text/css" media="only screen and (max-width: 900px), only screen and (max-device-width: 900px) and (-moz-max-device-pixel-ratio: 1.5), only screen and (max-device-width: 900px) and (-o-max-device-pixel-ratio: 1.5/1), only screen  and (max-device-width: 900px) and (-webkit-max-device-pixel-ratio: 1.5), only screen and (max-device-width: 900px) and (max-device-pixel-ratio: 1.5), only screen and (max-device-width: 1800px) and (-moz-min-device-pixel-ratio: 2), only screen and (max-device-width: 1800px) and (-o-min-device-pixel-ratio: 2/1), only screen and (max-device-width: 1800px) and (-webkit-min-device-pixel-ratio: 2), only screen and (max-device-width: 1800px) and (min-device-pixel-ratio: 2)"  />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/mobile.css" type="text/css" media="
	    	only screen and (max-width: 540px),
	    	only screen and (max-device-width: 540px) and (-moz-max-device-pixel-ratio: 1.5), 
	    	only screen and (max-device-width: 540px) and (-o-max-device-pixel-ratio: 1.5/1), 
	    	only screen and (max-device-width: 540px) and (-webkit-max-device-pixel-ratio: 1.5),
	    	only screen and (max-device-width: 540px) and (max-device-pixel-ratio: 1.5), 
	    	only screen and (max-device-width: 1080px) and (-webkit-min-device-pixel-ratio: 2), 
	    	only screen and (max-device-width: 1080px) and (-moz-min-device-pixel-ratio: 2),
	    	only screen and (max-device-width: 1080px) and (-o-min-device-pixel-ratio: 2/1),
	    	only screen and (max-device-width: 1080px) and (min-device-pixel-ratio: 2)"  />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/normalize.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/layout.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/joomla.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/system/system.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/template.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/menu/menu.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/gk.stuff.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/style1.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/override.css" type="text/css" />
  <link rel="stylesheet" href="http://www.thesentinel.com/pgs/plugins/system/gk_ajax_search/gk_ajax_search.css" type="text/css" />
  <style type="text/css">
.gkcol { width: 185px; }@media screen and (max-width: 675px) {
    	#k2Container .itemsContainer { width: 100%!important; } 
    	.cols-2 .column-1,
    	.cols-2 .column-2,
    	.cols-3 .column-1,
    	.cols-3 .column-2,
    	.cols-3 .column-3,
    	.demo-typo-col2,
    	.demo-typo-col3,
    	.demo-typo-col4 {width: 100%; }
    	}#system-message-container { margin: 0 -20px; }.gkMenu > ul > li a {
  padding-left: 6px;
  padding-right: 6px;
}
.gkMenu > ul > li { font-weight: bold;
  font-size: 16px;
}
#gkTopBar ul li a { font-weight: bold; color: #FFF; }
.gkFooter {color: #ffffff;
    font-size: 16px;
}

div.banneritem {text-align: center; padding-top: 20px } /* centers banner items without center tag */

#gkTopMenu {padding-top: 10px
}
#gkFooterNav strong {color: #fff;
}
/* tablet/mobile suffixes */
.notablet {
    display: block;
}
.nomobile {
    display: block;
}
gkTopBar ul li { /* to fit extra menu item */
	padding: 0 13px;
}#gkSidebar { width: 37%; }
#gkContent { width: 63%; }
#gkPage, #gkTopBar > div, .gkFooter, #gkBottom2 { max-width: 1020px; }
body { padding: 0 20px; }#menu321 > div,
#menu321 > div > .childcontent-inner { width: 185px; }
#menu749 > div,
#menu749 > div > .childcontent-inner { width: 185px; }
#menu758 > div,
#menu758 > div > .childcontent-inner { width: 185px; }

  </style>
  <script src="/pgs/media/system/js/mootools-core.js" type="text/javascript"></script>
  <script src="/pgs/media/system/js/core.js" type="text/javascript"></script>
  <script src="/pgs/media/system/js/modal.js" type="text/javascript"></script>
  <script src="//ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js" type="text/javascript"></script>
  <script src="/pgs/components/com_k2/js/k2.js?v2.6.7&amp;sitepath=/pgs/" type="text/javascript"></script>
  <script src="/pgs/components/com_rsform/assets/js/script.js" type="text/javascript"></script>
  <script src="/pgs/media/system/js/mootools-more.js" type="text/javascript"></script>
  <script src="http://www.thesentinel.com/pgs/templates/gk_gamenews/js/gk.scripts.js" type="text/javascript"></script>
  <script src="http://www.thesentinel.com/pgs/templates/gk_gamenews/js/gk.menu.js" type="text/javascript"></script>
  <script src="//pittpostgazette-d.openx.net/w/1.0/jstag?nc=6785150-BENN" type="text/javascript"></script>
  <script src="http://www.thesentinel.com/pgs/plugins/system/gk_ajax_search/gk_ajax_search.js" type="text/javascript"></script>
  <script type="text/javascript">

		window.addEvent('domready', function() {

			SqueezeBox.initialize({});
			SqueezeBox.assign($$('a.modal'), {
				parse: 'rel'
			});
		});
 $GKMenu = { height:false, width:false, duration: 500 };
$GK_TMPL_URL = "http://www.thesentinel.com/pgs/templates/gk_gamenews";

$GK_URL = "http://www.thesentinel.com/pgs/";

                                  window._taboola = window._taboola || [];
                                  _taboola.push({article:'auto'});
                                  !function (e, f, u) {
                                    e.async = 1;
                                    e.src = u;
                                    f.parentNode.insertBefore(e, f);
                                  }(document.createElement('script'),
                                  document.getElementsByTagName('script')[0],
                                  'http://cdn.taboola.com/libtrc/benn-thesentinel/loader.js');

			try{$Gavick;}catch(e){$Gavick = {};} $Gavick["gk_ajax_search"] = { "container_id": "gkSearch", "delay": "500", "length": "3", "lang_close": "Close", "lang_all_results": "View all results", "lang_no_results": "No results for specified phrase&hellip;" }
  </script>

    
<!--[if IE 9]>
<link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/ie/ie9.css" type="text/css" />
<![endif]-->

<!--[if IE 8]>
<link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/ie/ie8.css" type="text/css" />
<![endif]-->

<!--[if lte IE 7]>
<link rel="stylesheet" href="http://www.thesentinel.com/pgs/templates/gk_gamenews/css/ie/ie7.css" type="text/css" />
<![endif]-->

<!--[if (gte IE 6)&(lte IE 8)]>
<script type="text/javascript" src="http://www.thesentinel.com/pgs/templates/gk_gamenews/js/respond.js"></script>
<script type="text/javascript" src="http://www.thesentinel.com/pgs/templates/gk_gamenews/js/selectivizr.js"></script>
<script type="text/javascript" src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->	 </head>
<body data-mobile="true" data-tablet-width="940" data-mobile-width="580" data-bg="2">	
		
	
	<div id="gkPage">	 
	    	    
	    <section id="gkPageTop">                    	
		    
          <a href="./" id="gkLogo">
        <img src="http://www.thesentinel.com/pgs/images/Brand_Identity_Images/newheader.jpg" alt="Prince George's Sentinel" />
     </a>
     		    
		    <div id="gkMobileMenu">
		    	Menu		    	<select onChange="window.location.href=this.value;">
		    	<option  value="http://www.thesentinel.com/pgs/">Home</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=2&amp;Itemid=321">News</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=42&amp;Itemid=766">&nbsp;&nbsp;&raquo;Local</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=43&amp;Itemid=767">&nbsp;&nbsp;&raquo;State</option><option selected="selected"  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=3&amp;Itemid=323">Sports</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=26&amp;Itemid=748">Crime</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=49&amp;Itemid=799">Education Corner</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=27&amp;Itemid=749">Columns</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=28&amp;Itemid=750">&nbsp;&nbsp;&raquo;Editor's Notebook</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=31&amp;Itemid=753">&nbsp;&nbsp;&raquo;Sporting View</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=36&amp;Itemid=758">Entertainment</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=37&amp;Itemid=759">&nbsp;&nbsp;&raquo;Music</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=38&amp;Itemid=760">&nbsp;&nbsp;&raquo;Film</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=39&amp;Itemid=761">&nbsp;&nbsp;&raquo;Food</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=45&amp;Itemid=762">PDF Editions</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=40&amp;Itemid=763">Videos</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=4&amp;Itemid=677">Obituaries</option><option  value="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=35&amp;Itemid=757">Travel</option><option  value="/pgs/index.php?option=com_users&amp;view=login&amp;Itemid=584">Log In/Out</option>		    	</select>
		    </div>
		    
		    		    
		    		    <div id="gkMainMenu">
		    	<nav id="gkExtraMenu" class="gkMenu">
<ul class="gkmenu level0"><li  class="first"><a href="http://www.thesentinel.com/pgs/"  class=" first" id="menu798" title="Home" >Home</a></li><li  class="haschild"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=2&amp;Itemid=321"  class=" haschild" id="menu321" title="News" >News</a><div class="childcontent">
<div class="childcontent-inner">
<div class="gkcol gkcol1  first"><ul class="gkmenu level1"><li  class="first"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=42&amp;Itemid=766"  class=" first" id="menu766" title="Local" >Local</a></li><li  class="last"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=43&amp;Itemid=767"  class=" last" id="menu767" title="State" >State</a></li></ul></div>
</div>
</div></li><li  class="active"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=3&amp;Itemid=323"  class=" active" id="menu323" title="Sports" >Sports</a></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=26&amp;Itemid=748"  id="menu748" title="Crime" >Crime</a></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=49&amp;Itemid=799"  id="menu799" title="Education Corner" >Education Corner</a></li><li  class="haschild"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=27&amp;Itemid=749"  class=" haschild" id="menu749" title="Columns" >Columns</a><div class="childcontent">
<div class="childcontent-inner">
<div class="gkcol gkcol1  first"><ul class="gkmenu level1"><li  class="first"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=28&amp;Itemid=750"  class=" first" id="menu750" title="Editor's Notebook" >Editor's Notebook</a></li><li  class="last"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=31&amp;Itemid=753"  class=" last" id="menu753" title="Sporting View" >Sporting View</a></li></ul></div>
</div>
</div></li><li  class="haschild"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=36&amp;Itemid=758"  class=" haschild" id="menu758" title="Entertainment" >Entertainment</a><div class="childcontent">
<div class="childcontent-inner">
<div class="gkcol gkcol1  first"><ul class="gkmenu level1"><li  class="first"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=37&amp;Itemid=759"  class=" first" id="menu759" title="Music" >Music</a></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=38&amp;Itemid=760"  id="menu760" title="Film" >Film</a></li><li  class="last"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=39&amp;Itemid=761"  class=" last" id="menu761" title="Food" >Food</a></li></ul></div>
</div>
</div></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=45&amp;Itemid=762"  id="menu762" title="PDF Editions" >PDF Editions</a></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=40&amp;Itemid=763"  id="menu763" title="Videos" >Videos</a></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=4&amp;Itemid=677"  id="menu677" title="Obituaries" >Obituaries</a></li><li ><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=35&amp;Itemid=757"  id="menu757" title="Travel" >Travel</a></li><li  class="last"><a href="/pgs/index.php?option=com_users&amp;view=login&amp;Itemid=584"  class=" last" id="menu584" title="Log In/Out" >Log In/Out</a></li></ul>
</nav>   
	    	</div>
	    		    	
	    		    	<nav id="gkTopMenu">
	    		<div class="bannergroup">


</div>


<div class="custom box onlymobile"  >

	<!-- Beginning PassBack for Ad unit BENN/Sentinel ### size: [[320,50]] -->
	<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('6785150/BENN/Sentinel', [[320,50]]).display();
	</script>
<!-- End Passback -->	
</div>


<div class="custom"  >

	<center>
<!-- Beginning PassBack for Ad unit BENN/The_Sentinel/pgs ### size: [[728,90]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/The_Sentinel/pgs', [[728,90]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->
</center>	
</div>


<div class="custom"  >

		
</div>

	    	</nav>
	    		    </section>
	
		<div id="gkPageContent">
					 
	    	<section id="gkContent">					
								
								
					
				
								
				<section id="gkMainbody">
											<article id="k2Container" class="itemView">  				<header>
												<h1> Charles H. Flowers celebrates six football college commits										</h1>
								<ul>
												<li class="itemDate">
								<time datetime="2017-02-07"> 07 Feb 2017 </time>
						</li>
																		<li class="itemAuthor"> Written by&nbsp;
																Candace Rojo Keyes														</li>
																		<li class="itemCategory"> <span>Published in</span> <a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;task=category&amp;id=3:sports&amp;Itemid=323">Sports</a> </li>
																		<li class="itemHits"> Read <strong>20</strong> times </li>
																		<li class="itemResizer"> <span>font size</span> <a href="#" id="fontDecrease">decrease font size</a> <a href="#" id="fontIncrease">increase font size</a> </li>
																		<li class="itemPrint"> <a rel="nofollow" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3399:charles-h-flowers-celebrates-six-football-college-commits&amp;Itemid=323&amp;tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> Print </a> </li>
																		<li class="itemEmail"> <a rel="nofollow" href="/pgs/index.php?option=com_mailto&amp;tmpl=component&amp;template=gk_gamenews&amp;link=92969edb1363bbf941ca6b1c2112986330ea4aa4" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> Email </a> </li>
																																		</ul>
						</header>
		 				<div class="itemBody">  												<div class="itemIntroText"> <p><img src="images/FlowerNSD_01.jpg" alt="FlowerNSD 01" style="margin: 8px; border: 3px solid #000000; float: left;" height="323" width="487" />SPRINGDALE – Charles H. Flowers Head Football Coach Dameon Powell could not hide his joy as he talked about his players and their futures.</p>
 </div>
																<div class="itemFullText"> 
<p>Last week, during a National Signing Day Ceremony, Powell took his time with each of the six athletes gathered to put ink to their college letters of intent. While six were gathered to sign that day, Powell bragged six more were soon to follow.</p>
<p>“This means so much to me as their coach because these are the times that we live for. This is why we do what we do – days like this when we know that we’re sending our boys to another level,” Powell said.</p>
<p>Flowers’ Principal Gorman Brown often refers to the high school as a “Mecca of Excellence” and said that is evident in the football players they are sending to college.</p>
<p>Delani Carter, Tereek Isaacs, Robert Nicholas, Malcolm Johnson, Joshua Hicks and Donovan Smith are all examples.</p>
<p>“I came up to each of you and shook your hands because I’m proud of you. Not just as your principal - because I’m very proud as the principal of Charles Herbert Flowers High School - but as a father, a father of sons,” Browns said. “Sons that we want nothing more for but to embrace manhood at the level that you guys have done. I am very proud of what you have begun to accomplish.”</p>
<p>Powell said throughout their high school careers, these athletes did everything asked of them.</p>
<p>During the ceremony, Powell talked up Isaacs as a serious scholar who did everything he could to get to the next level. Isaacs committed to Sheppard University to play for the Rams.</p>
<p>“I want to thank my parents and my coaches for believing in me, and I want to thank the coaches at Sheppard for giving a chance to play at the next level,” he said.</p>
<p>Powell described Nicholas as a “tough son of a cookie” with a bright future. He committed to Bethany College to play for the Swedes.</p>
<p>Nicholas said he owed thanks to his parents for putting him in the position to go to college and to his coaches for giving him the “opportunity to shine.”</p>
<p>Johnson is a man of confidence who is short in stature, but a player with speed who can hit hard, Powell said. He also hit the books hard and will graduate with a 3.9 grade point average. He committed to Howard University.</p>
<p>“I’m extremely blessed and humbled to say that today I will be signing my national letter of intent to attend Howard University on a full scholarship, and I’m 110 percent committed,” Johnson said.</p>
<p>Hicks is another Flowers scholar-athlete who will graduate with a 3.9. Powell also described him as the heart and soul of the team who goes “above and beyond” to get what he wants. He committed to the College of the Holy Cross.</p>
<p>He signed to the school on a full ride scholarship.</p>
<p>Carter will attend West Point where he plans to walk on for Army Football. Powell described him as an upfront guy who set rigorous goals for himself and met them.</p>
<p>Smith is one of those students with tons of potential, Powell said, and the coach wishes he had more time with Smith to help groom him. Smith committed to Lake Erie College and Powell has no doubt that he will become one of the best on their team.</p>
<p>“It’s been a hard time for us,” Smith said, thanking God for this opportunity. “This last year, it has just been a blessing,”</p>
<p>Next year Principal Brown wants to hold the National Signing Day ceremony in the auditorium because he expects more Flowers athletes to sign on the dotted line. Powell said that is dependent upon the players who signed this year.</p>
<p>“When you leave here and you perform at a high level, not only are they going to remember you, but they’re always going to want to come back here and find another you,” Powell said. “But if you leave and you don’t put everything into it, you will never see that school back here again.”</p>
<p><img src="images/1.CandaceBio.png" alt="1.CandaceBio" style="float: left;" height="141" width="350" /></p> </div>
																 <!-- taboola custom ad code start -->
                <div id="taboola-below-article-thumbnails"></div>
                <script type="text/javascript">
                window._taboola = window._taboola || [];
                _taboola.push({
                        mode: 'thumbnails-a',
                        container: 'taboola-below-article-thumbnails',
                        placement: 'Below Article Thumbnails',
                        target_type: 'mix'
                        });
                </script>
                <script type="text/javascript">
                        window._taboola = window._taboola || [];
                        _taboola.push({flush: true});
                </script>
<!-- taboola custom ad code end -->
								<div class="itemLinks">
																		<div class="itemRatingBlock"> <span>Rate this item</span>
								<div class="itemRatingForm">
										<ul class="itemRatingList">
												<li class="itemCurrentRating" id="itemCurrentRating3399" style="width:0%;"></li>
												<li> <a href="#" rel="3399" title="1 star out of 5" class="one-star">1</a> </li>
												<li> <a href="#" rel="3399" title="2 stars out of 5" class="two-stars">2</a> </li>
												<li> <a href="#" rel="3399" title="3 stars out of 5" class="three-stars">3</a> </li>
												<li> <a href="#" rel="3399" title="4 stars out of 5" class="four-stars">4</a> </li>
												<li> <a href="#" rel="3399" title="5 stars out of 5" class="five-stars">5</a> </li>
										</ul>
										<div id="itemRatingLog3399" class="itemRatingLog">(0 votes)</div>
								</div>
						</div>
																		<div class="itemTagsBlock"> <span>Tagged under</span>
								<ul class="itemTags">
																				<li> <a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;task=tag&amp;tag=Candace%20Rojo%20Keyes&amp;Itemid=323">Candace Rojo Keyes</a> </li>
																				<li> <a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;task=tag&amp;tag=Flowers%20High%20School&amp;Itemid=323">Flowers High School</a> </li>
																				<li> <a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;task=tag&amp;tag=high%20school%20football&amp;Itemid=323">high school football</a> </li>
																				<li> <a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;task=tag&amp;tag=National%20Signing%20Day&amp;Itemid=323">National Signing Day</a> </li>
																		</ul>
						</div>
																		<div class="itemSocialSharing">
																<div class="itemTwitterButton"> <a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal">Tweet</a> 
										<script type="text/javascript" src="//platform.twitter.com/widgets.js"></script> 
								</div>
																								<div class="itemFacebookButton">
										<div id="fb-root"></div>
										<script type="text/javascript">
		                            (function(d, s, id) {
		                              var js, fjs = d.getElementsByTagName(s)[0];
		                              if (d.getElementById(id)) {return;}
		                              js = d.createElement(s); js.id = id;
		                              js.src = "//connect.facebook.net/en_US/all.js#appId=177111755694317&xfbml=1";
		                              fjs.parentNode.insertBefore(js, fjs);
		                            }(document, 'script', 'facebook-jssdk'));
		                    </script>
										<div class="fb-like" data-send="false" data-width="260" data-show-faces="true"></div>
								</div>
																								<div class="itemGooglePlusOneButton">
										<g:plusone annotation="inline" width="120"></g:plusone>
										<script type="text/javascript">
		                          (function() {
		                            window.___gcfg = {lang: 'en'}; // Define button default language here
		                            var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
		                            po.src = 'https://apis.google.com/js/plusone.js';
		                            var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		                          })();
		                    </script> 
								</div>
														</div>
										</div>
																<div class="itemAuthorContent">
						<h3>Related items</h3>
						<ul>
																<li class="even"> <a class="itemRelTitle" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3401:dematha-s-young-chooses-ohio-st-mcfarland-and-minor-to-maryland&amp;Itemid=323">DeMatha&#039;s Young chooses Ohio St., McFarland and Minor to Maryland</a> </li>
																<li class="odd"> <a class="itemRelTitle" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3398:wise-has-nine-players-commit-on-national-signing-day&amp;Itemid=323">Wise has nine players commit on National Signing Day</a> </li>
																<li class="even"> <a class="itemRelTitle" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3397:video-riverdale-baptist-s-castro-fields-chooses-penn-state&amp;Itemid=323">VIDEO: Riverdale Baptist&#039;s Castro-Fields chooses Penn State</a> </li>
																<li class="odd"> <a class="itemRelTitle" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3390:special-education-advocates-request-more-support&amp;Itemid=766">Special education advocates request more support</a> </li>
																<li class="even"> <a class="itemRelTitle" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3389:whitehall-elementary-wins-county-s-only-egate-award&amp;Itemid=766">Whitehall Elementary wins county&#039;s only EGATE award</a> </li>
														</ul>
				</div>
																								<div class="itemNavigation"> <span>More in this category:</span>
												<a class="itemPrevious" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3398:wise-has-nine-players-commit-on-national-signing-day&amp;Itemid=323">&laquo; Wise has nine players commit on National Signing Day</a>
																		<a class="itemNext" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3400:guihon-reid-power-lady-lions-to-lopsided-victory&amp;Itemid=323">Guihon, Reid power Lady Lions to lopsided victory &raquo;</a>
										</div>
								  </div>
						<div class="itemComments" id="itemCommentsAnchor">
																				<div>Login to post comments</div>
						</div>
						<a class="itemBackToTop" href="/pgs/index.php?option=com_k2&amp;view=item&amp;id=3399:charles-h-flowers-celebrates-six-football-college-commits&amp;Itemid=323#"> back to top </a>
		</article>

<!-- JoomlaWorks "K2" (v2.6.7) | Learn more about K2 at http://getk2.org -->


									</section>
				
								<section id="gkMainbodyBottom">
					<div class="box  nomargin"><div><h3 class="header"><span id="module313">What Do You Think?</span></h3><div class="content">

<div class="custom"  >

	<!-- BENN Poll Widget Spot -->
<div id="benn-poll-iframe-container"></div>
	
</div>
</div></div></div>
				</section>
					    	</section>
	    	
	    		    	<aside id="gkSidebar">
	    		<div class="box  nomargin"><div><div class="content"><form action="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=3&amp;Itemid=323" method="post">
	<div class="search">
		<input name="searchword" id="mod-search-searchword" maxlength="20"  class="inputbox" type="text" size="30" value="Search..."  onblur="if (this.value=='') this.value='Search...';" onfocus="if (this.value=='Search...') this.value='';" /><input type="submit" value="Search" class="button" onclick="this.form.searchword.focus();"/>	<input type="hidden" name="task" value="search" />
	<input type="hidden" name="option" value="com_search" />
	<input type="hidden" name="Itemid" value="9999" />
	</div>
</form>
</div></div></div><div class="box "><div><div class="content">

<div class="custom"  >

	<!-- Beginning PassBack for Ad unit BENN/The_Sentinel/pgs ### size: [[300,250]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/The_Sentinel/pgs', [[300,250]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->

	
</div>
</div></div></div><div class="box "><div><div class="content">

<div class="custom"  >

	<!-- Beginning PassBack for Ad unit BENN/The_Sentinel/pgs ### size: [[160,600]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/The_Sentinel/pgs', [[160,600]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->
	
</div>
</div></div></div><div class="box "><div><div class="content"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/pgs/index.php?option=com_banners&amp;task=click&amp;id=79" target="_blank"
							title="Local Sidebar 1">
							<img
								src="http://www.thesentinel.com/pgs/images/Brand_Identity_Images/weekly-edition/weekly-pdf.jpg"
								alt="Local Sidebar 1"
																							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="box  banners-local-sidebar"><div><div class="content"><div class="bannergroup banners-local-sidebar">


</div>
</div></div></div><div class="box "><div><div class="content">

<div class="custom"  >

	<!-- Beginning PassBack for Ad unit BENN/The_Sentinel/pgs ### size: [[160,600]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/The_Sentinel/pgs', [[160,600]]).setTargeting('fold',['BTF']).display();
</script>
<!-- End Passback -->
	
</div>
</div></div></div><div class="box "><div><div class="content">

<div class="custom"  >

	<!-- Beginning PassBack for Ad unit BENN/The_Sentinel/pgs ### size: [[300,250]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/The_Sentinel/pgs', [[300,250]]).setTargeting('fold',['BTF']).display();
</script>
<!-- End Passback -->
	
</div>
</div></div></div><div class="box "><div><div class="content">

<div class="custom"  >

		
</div>
</div></div></div>
	    	</aside>
	    			</div>
		    
		    </div> 
    
        <section id="gkBottom2" class="gkCols6">
    	<div>
    		<div class="box  gkmod-1 nomargin"><div><div class="content">

<div class="custom"  >

	<center>
<!-- Beginning PassBack for Ad unit BENN/The_Sentinel/pgs ### size: [[728,90]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/The_Sentinel/pgs', [[728,90]]).setTargeting('fold',['BTF']).display();
</script>
<!-- End Passback -->
</center>	
</div>
</div></div></div>
    	</div>
    </section>
        
    
<footer class="gkFooter">
		
		<div id="gkFooterNav">
		

<div class="custom"  >

	<p id="gkCopyrights"><span style="font-size: 10pt; color: #ccffff;"><strong><a href="index.php?option=com_wrapper&amp;view=wrapper&amp;Itemid=508"><span style="font-family: arial,helvetica,sans-serif;"><span style="color: #00ccff;">Privacy Policy</span></span></a>&nbsp;&nbsp;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;<strong><span style="font-family: arial,helvetica,sans-serif; color: #ccffff;"><a href="http://http//www.post-gazette.com/"><span style="color: #00ccff;">&nbsp;&nbsp;</span></a></span></strong></strong></span></p>
<div style="color: #ccffcc; font-family: arial,helvetica,sans-serif; font-size: 10pt; line-height: 2em;">
<p>The Montgomery County Sentinel, published weekly by Berlyn, Inc., is a community newspaper covering Montgomery County, Maryland. Founded in 1855.</p>
<p>The Prince George's Sentinel, published weekly by Berlyn Inc., is a community newspaper covering Prince George's County, Maryland.</p>
<p>©Berlyn, Incorporated. All rights reserved.</p>
</div>
<p>&nbsp;</p>	
</div>


<div class="custom"  >

	<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-38763466-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>	
</div>


<div class="custom"  >

	<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WJ36PN"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WJ36PN');</script>
<!-- End Google Tag Manager -->	
</div>


<div class="custom"  >

	<!-- BENN Poll Widget Initialization Code -->
<script type="text/javascript">
var benn_siteid="sentinelpgs-sports";
</script>
<script src="http://widget.post-gazette.com/poll/bennpollinit.js"></script>	
</div>

	</div>
		
		
		<p class="gkCopyrights">&nbsp;</p>
	</footer>    
        <div id="gkTopBar">
    	<div>
    		    		<div class="social-icons">
    			

<div class="custom"  >

	<div class="social-icons">
<div class="custom">
<p><a class="gkFb" href="https://www.facebook.com/pages/The-Prince-Georges-Sentinel/262879958042">Facebook</a> <a class="gkTwitter" href="https://twitter.com/PGSentinel">Twitter</a> <a class="gkGplus" href="#">Google+</a> <a class="gkRss" href="#">RSS</a></p>
</div>
</div>	
</div>

    		</div>
    		    		
    		
    		    		<nav>
    			
<ul class="menu">
<li class="item-797"><a href="http://www.thesentinel.com/mont/pay-invoice" >Pay Invoice</a></li><li class="item-511"><a href="https://thesentinel.smugmug.com" target="_blank" >Photo Gallery</a></li><li class="item-683"><a href="/pgs/index.php?option=com_k2&amp;view=item&amp;layout=item&amp;id=230&amp;Itemid=683" >Contact</a></li><li class="item-684"><a href="/pgs/index.php?option=com_rsmembership&amp;view=categories&amp;Itemid=684" >Subscribe</a></li><li class="item-764"><a href="/pgs/index.php?option=com_jcalpro&amp;view=events&amp;layout=month&amp;Itemid=764" >Calendar</a></li><li class="item-697"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=18&amp;Itemid=697" >Classifieds</a></li><li class="item-685"><a href="http://thesentinel.com/pgs/images/Brand_Identity_Images/Sentinel%20RateCard_2015.pdf" >Advertise</a></li><li class="item-692"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=46&amp;Itemid=692" >Archive</a></li><li class="item-765"><a href="/pgs/index.php?option=com_k2&amp;view=itemlist&amp;layout=category&amp;task=category&amp;id=41&amp;Itemid=765" >Political Cartoons</a></li><li class="item-791"><a href="/pgs/index.php?option=com_kunena&amp;view=home&amp;defaultmenu=152&amp;Itemid=791" >Forum</a></li></ul>

    		</nav>
    		    		
    		    	</div>
    </div>
        	
   	

<div id="gkfb-root"></div>
<script type="text/javascript">

//<![CDATA[
   	window.fbAsyncInit = function() {
		FB.init({ appId: '', 
			status: true, 
			cookie: true,
			xfbml: true,
			oauth: true
		});
   		    
	  		};
    //      
   window.addEvent('load', function(){
        (function(){
                if(!document.getElementById('fb-root')) {
                     var root = document.createElement('div');
                     root.id = 'fb-root';
                     document.getElementById('gkfb-root').appendChild(root);
                     var e = document.createElement('script');
                 e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
                     e.async = true;
                 document.getElementById('fb-root').appendChild(e);   
                }
        }());
    }); 
    //]]>
</script>


<!-- +1 button -->

<!-- twitter -->


<!-- Pinterest script --> 

	
</body>
</html>
